3D Inverted Floor Fixtures strange PAN behaviour

  • Hello everybody,


    I'm struggeling with the pan invert possibility of the 3D view.

    I’ve two fixtures, one for the roof, the other for the floor. The floor fixture is rotated by 180 degree around y axis.

    To have both fixtures pointing in the same direction I created a copy of the original profile, inverted the DMX for PAN in the profile and swapped the physical pan values for the fixture in the profile.

    Now it works fine, so if I apply e.g. 40% for PAN on both fixtures then both point in the same direction.


    But if now PAN DMX Invert is set in the patch for both fixtures, they point again in opposite directions in 3D. This does not change even if PAN DMX Invert is disabled again. The only possibility to get them pointing again in the same direction is to set the physical direction in the floor profile back to the original values and reapply the inverted physical values as described above.

    I observed this behavior with different fixtures and from my point of view applying PAN DMX Invert should not affect 3D at all?


    To sum up, that means after applying and removing the PAN DMX invert the fixture points in the opposite direction as before for the same 40% value.


    Anybody has an idea what's going wrong here?

  • Thanks for the answer.

    Unfortunatelly I'm aware about this behaviour. The problem by simply inverting the encoders is, that it does not apply to the calculator. So if I enter the same number for the top and floor fixture, they won't point in the same direction.


    That's why I have two copies of the same fixture one with -240° to 240° and normal dmx pan and one with 240° and -240° and inverted dmx pan. (The invert is directly in the fixture profile). This works fine and I can use encoders and calculator and both fixtures will point in the same directionin 3D. But as soon as I do anything with the DMX invert setting in the patch, both fixtures point in the opposite direction in 3D regardless of the DMX invert setting.

    It seems that somehow the DMX invert setting swaps the pysical values of the fixture internally, because the only way to get it working correct again is to set the physicap values in the fixture back to original and swap them again.


    The problem is quiet difficult to describe, it already took me a quiet long time to figure out this strange behaviour.