Just in case

  • I count 3 clicks to enable it, is that really a concern?

    The procedure necessary to enable AutoSave was not my concern.


    For all other software I know enabling AutoSave is a global setting - not a per document setting...


    I use AutoSave because I sometimes forget to save.

    Having then to remember to enable AutoSave is prone to the same problem (Forgetting)

    That's what happened when I lost one hour Fixture Type editing last night.


    I guess what I really want is AutoSave as a global setting / User setting.

  • I have managed two myself in a couple of days.

    One in Patch and one in Fixture sheet

    It seems like it depends on the show size for me - on shows with less fixtures I get less crashes, on shows with more fixtures I get more crashes. I use the same programming/syntax techniques on both but bigger shows = more crashes. I use Mode 2 for bigger shows now...

  • Clintos and Ryan Kanarek


    These crashes has not been reported.


    First of all because I could not reproduce them easily.

    But also because I struggle to find a meaningful way to report bugs in general.


    To be meaningful ...

    - If I've spent one hour to find how to reproduce and send 3 simple steps please try them instead of asking me to prepare showfile.

    - Instead of assuming I must be wrong because 'nobody else have seen this' give it a try.


    I would need a minimum of feedback

    - A confirmation that it is indeed a bug (Or explanation on what I did wrong)

    - A confirmation that it has been passed on to MA for investigation. (Most developers would then supply you with a reference..)


    I've tried everything - Forum, distributor and directly to MA. Very low success rate.

    I have multiple issues my distributor have forwarded to MA months ago.



    Bottom line - I like to help because I bought this thing and need it to work.

    Problem is it takes SOO much time. I find small bugs almost every time I sit down with the console.

    I usually make a small note of it. I have plenty of those.

  • Im very sorry go hear this.
    I’m sure Ryan will look into how things can be improved here. This is not the sort of experience you should be having, especially when doing the valuable efforts of bug finding.
    Please feel free to PM me anytime if you need assistance. Happy to test and report bugs for you.

  • One would like to think I was exaggerating earlier - but here are my notes from today:


    Fixture Type edit - Long name does not 'stick'

    MATricks - All text in the interface disappeared

    Sequence - Got two selected at once

    Preset - Trouble deleting presets, some went gray, some no reaction at all.

    Recipe - The entered recipes did not show up in the Sequence sheet

  • (I'm not in front of the software at the moment to look at LongName for FixtureTypes.)


    Regarding MAtricks text disappearing, are you by any chance using Andreas's Selection Tools plugin? If so, note that he posted an updated version for v1.4 because of this issue.


    Selecting multiple Sequences is a feature, not a bug. You could do the same in MA2 (with Executors of course, rather than Sequences).


    Regarding trouble deleting Presets, just to double-check, you weren't in a World at the time, correct? Or have fixtures in your show file for which you had removed their ID but still had data in the Preset?


    Regarding Recipes, can you make this happen consistently? What was your workflow here?

  • Ryan Kanarek

    This was of course not meant as bug reports but I appreciate your answer.


    MAtricks: Used old plugin

    Multiple Sequ: OK, I did not leave enough time between press on SELECT and EXEC and it seemed random.

    Presets: Sorry - was some Globals I had forgot.

    Recipes: Consistently yesterday - not today. Pressing Edit + Exec and Recipe just showed VERY briefly

    (Long names is the same today)

  • Ryan Kanarek
    I'm curious if you reproduced and reported the 'Long names won't stick' issue? (Fixture Type edit)


    And about the multi-select function, is the procedure that you should hold select-button pressed while selecting several objects?

    As mentioned I get multi selection unintentionally when I work fast so maybe it should be adjusted so you actually need to hold it until selected?

    Or maybe I should work with one hand on my back :-)

  • Hi Jan,


    The longname issue has been reproduced and reported.


    The multi-select feature is activated by keeping the select-key pressed, while tapping the exec-buttons.


    I agree that the press-release status detection could be improved to reduce chances of unintentional multi-select during fast operation.


    In the meantime you could create your own Select button without this feature, by creating a macro with a macroline with Command = Select, Execute = No, and assign the macro to e.g. X9