Grandmaster knob clic setup

  • Yes, that's exactly what I was asking me too!!! I searched everywhere but there is no way to set this function so far. Even the manual is not saying anything about that!

    I'm a switcher from Chamsys-System to MA3. Having a MA3-Wing, Vizkey, and 2K onPC-Node.

  • I think someone asked this some time ago (memory is fading me), I don't think the click can be assigned yet on the GrandMaster.


    I just tried this one liner that toggles the fader, it moves the GrandMaster fader correctly but unfortunately it does not affect the output of the desk. I'm sure I missed something simple.


    Again the below script on it's own does not work:


    Code
    1. lua'local o = Root().ShowData.Masters.Grand.Master; local v = "NormedValue"; if o[v] == 0 then o[v] = 100 elseif o[v] == 100 then o[v] = 0 else  o[v] = 0 end'


    Perhaps someone knows what I missed.

  • hoss

    it is not an issue with your lua, you will see the same behavior with commandline:

    Set Master "Grand"."Master" Property "NormedValue" 0


    Masterlevels are realtime parameters (adjustable by executorfaders), changing these realtime parameters does update the object property, but (currently) merely changing the object property doesn't adjust the realtime-level


    you could adapt your script to set the actual realtime-level rather than the property:

    Cmd('Master "Grand"."Master" At 0') 


    If you want to toggle a blackout you could also use regular commandline and utilize the Black function

    Black Toggle Master "Grand"."Master"

    just be aware that the Black function is primary intended as a press/unpress hardkey function assigned to exec buttons and there is currently no indication that the Black function has been enabled in its pressed state via commandline

  • I always forget the Set syntax, I tried and failed with it, but this makes the toggle macro much more simple:


    Code
    1. lua'if Root().ShowData.Masters.Grand.Master.NormedValue == 0 then Cmd([[Master "Grand"."Master" At 100]]) else Cmd([[Master "Grand"."Master" At 0]]) end'

    I bit myself with the Black function once before... never again :)

  • There's any variant to doit flat mode not toggle?