• Hello everyone

    I work with version 1.1.3.2 and i wanna regulate a normally dimmerfader with syntax "fadermaster sequence 8 at 100 fade 3". The fader jumps direct to 100%, without a fade of 3 seconds. Why that? Why don't work the keyword "fade" anymore?


    Thanks for help, i tried a lot.

  • Hello Bjoern, hello Hoss

    Thank you very much for helping.


    Exactly Hoss, i'm looking for this syntax. Why is it not working like that with grandma3? They changend something?

  • I'm sure it will be added back in the future; Between ma2 and ma3 they basically changed everything :)


    Mostly because I have too much time on my hands and I wanted to see if I could do it I made a Plugin called Fade Master they mimics the functionality.


    It allows you do enter Plugin "Fade Master" "Page,1.201,100,3 or Plugin "Fade Master" "Sequence,8,100,3 to fade a master.


    There are other options but It's on the page.


    As always, Caveat emptor.

  • I agree the syntax is a little obtuse, but as far as I know the only way to pass options to a plugin is with a string following the name of the plugin.


    It could however assume some things and that would make it simpler.


    For example I could assume that if there is a dot that means a page and else it's a sequence.


    That could simplify it to:


    Plugin "Fade Master" "1.201,100,3"



    Another option have used in previous plugins is using a dialog to ask all the questions. I might take a look at that this week as it's simple to do.

  • Another option is to enable and set timed execution (in deciseconds) before passing the FaderMaster command to the sequence:


    On Master "Grand"."ExecTime"

    Master "Grand"."ExecTime" At 30

    FaderMaster Sequence 8 At 100

    Off Master "Grand"."ExecTime"

  • I added a new version that shows a dialog when you run the plugin without arguments. Also I made the "Page"/"Sequence" argument optional.




    Andreas, It looks like you don't need to turn the ExecTime On as then setting the time turns it on. Also it looks like the only way to stop it from running it to take the fader down to 0, though since you can only do 10 seconds that's not too much of an issue.


    Also I created two macros and executing two faders at 3 seconds, and randomly a fader will go from 0 to 100 at 0 seconds and the DMX will either run at the desired 3 seconds or sometime snap at 0 seconds.

  • hi hoss,


    you are right, setting a value above 0 seems to automatically enable the exectime master, I was not aware of that.


    Please try to add some small wait-times (0.033s) in your macrolines, to force the commands to be executed in different calculation cycles, maybe that would improve stability.