Store cue only

  • Hi, I've followed this example from the manual but the result doesn't seem to be the same.

    Doing the following steps:

    results in this:

    Interestingly the command I actually typed is this so it might be that this was mistakenly included in the documentation rather than a bug in the software:


    If this is something we can't currently do (either because it's a bug or not implemented yet) can anyone think of a good work around for the moment?


    Thanks!

  • this section of the manual seems to be a little ahead of time.


    in the releasenotes of v1.0.0.3, Cue Only is listed as yet to come...


    As a workaround you can try the Block and Unblock command


    e.g. blocking the whole sequence while you do a store that you don't want to track:


    Block

    Store cue 2 /merge

    Unblock

  • Thanks Andreas. A bit sad that unblocking the sequence will unblock any previously blocked cues (eg. Blackouts) but that's definitely manageable for the moment.


    I've just tried to put this in a macro that looks like this:

    Block

    Store cue (Cue number?) /merge

    Unblock


    However, the result is:

    Store cue "2" /merge


    Any idea how to fix that so there's no quotation marks?

  • reg quotes

    I believe the (popup) currently always will return a string, which is by default gets quoted.


    you could do this:


    Block

    Store Cue /merge

    Unblock


    and disable the execute property of macroline 2, to enter the cue number without a popup


    regarding deliberate block cues

    you could finish the macro off with a forth line that reblocks cues based on their names or part of their names:

    e.g.

    Block Cue "Blackout"

    or

    Block Cue "*Block"

  • Andreas will know much better than I but it seems that the block command does not use the programmer but instead works on the selected sequence or specific cue in that sequence.


    So to get a cue only you need to build the cue and then block it.


    Store Cue 3

    Block Cue 3


    Same goes for Unblock if you only want to unblock cue 3 and not the whole selected sequence you would enter


    Unblock Cue 3


    I was going to suggest a Macro, but it looks like UserVars are not fully implemented yet:


    SetUserVar CueOnly (NOTE: Must have a space after CueOnly), Change Execute to NO on this line

    Store Cue $CueOnly

    Block Cue $CueOnly

    DelUserVar CueOnly


    That way you touch the macro it leave you in the command line to type a cue number, then uses that number for both the Store and Block operations.


    However, this enters the right thing in the command line but entering 1 saves cue 0.001 for some reason. $ isn't listed in the manual so my guess is it's not implemented yet.