illegal instruction:4

  • Hi everyone,

    Code
    1. First of all I want to apologize for my English.
    2. The problem I have is that when I try to run the MAONPC I get a popup where it links me directly to the computer terminal. In the terminal it tells me that I have the following error: illegal instruction: 4. My software is MACOS HIGH SIERRA and in theory it is compatible with MAONPC. I don't know if it's a problem that has happened to someone else and if it can be solved in any way. I have tried to install it several times but the same thing continues. Can somebody help me? See attached photos FYI. Thanks in advance!
  • The main things you are looking for are:

    • Processor Cores and Speed
    • RAM (8G Min)
    • SSE 4.2 Support
    • VRAM (1G Min)
    • OpenGL 4.1 Support


    If you are unsure you can take a look at the system Information to see how your Mac shapes up. Click on the Apple Menu while holding down Option (Alt) on the keyboard the first option should be System Information...


    The first section on this window (Hardware) gives you a good rundown on the features of your mac. Here is mine, but be sure not to copy share your SN or Hardware UUID:


    Model Name: MacBook Pro

    Model Identifier: MacBookPro14,3

    Processor Name: Quad-Core Intel Core i7

    Processor Speed: 3.1 GHz

    Number of Processors: 1

    Total Number of Cores: 4

    L2 Cache (per Core): 256 KB

    L3 Cache: 8 MB

    Hyper-Threading Technology: Enabled

    Memory: 16 GB


    If you want to know if your CPU supports SSE 4.2 you can either look it up or download MacCPUID from Intel. in CPUID if you go to the features tab and scroll down until you see SSE4_2 is should be checked.



    Under Graphics/Display of System Information take the better of the graphics cards if you have more then one, it contains your VRAM and card name


    If you want to know if your graphics card supports OpenGL 4.1 you can take a look at this list and find your card.



    My guess is most of the issues are because of Missing SSE 4.2 or OpenGL 4.1 support.


    It would be nice if in future versions of the onPC software it would warn of any deficiencies in the log.