Posts by Svenwitt

BECOME PART OF THE COMMUNITY - Sign up here

    In the Lua string:

    Lua "local s,p,o=2,2,1000 for _,w in ipairs(ObjectList('ScreenContent '..s..'.*')) do if w.Name=='WindowPresetPool' and w.PresetPoolType==p-1 then w.WindowScrollPositions.ScrollV=o..','..o end end"


    I wanna have a user variable like

    Lua "local s,p,o=2,2,$Offset for _,w in ipairs(ObjectList('ScreenContent '..s..'.*')) do if w.Name=='WindowPresetPool' and w.PresetPoolType==p-1 then w.WindowScrollPositions.ScrollV=o..','..o end end"

    Does anyone know how i can create this in this macro ?

    Reason i wanna have this is that i want to add calculations to it.

    Thanks

    In the Lua string:
    Lua "local s,p,o=2,2,1000 for _,w in ipairs(ObjectList('ScreenContent '..s..'.*')) do if w.Name=='WindowPresetPool' and w.PresetPoolType==p-1 then w.WindowScrollPositions.ScrollV=o..','..o end end"


    I wanna have a user variable like


    Lua "local s,p,o=2,2,$Offset for _,w in ipairs(ObjectList('ScreenContent '..s..'.*')) do if w.Name=='WindowPresetPool' and w.PresetPoolType==p-1 then w.WindowScrollPositions.ScrollV=o..','..o end end"

    Does anyone know how i can create this in this macro ?
    Reason i wanna have this is that i want to add calculations to it.

    Thanks

    Hello,


    I've got a question, i dont know if its a but or a feature,

    Im making a Macro with the following lines:

    SetUserVar SongName (SongName?)
    SetUserVar SongNr (SongNumber?)

    Label page $SongNr $SongName

    This all works fine untill i start my Songname with a T or with a M or all the Grandma Shortcuts.
    This means,
    When i fill in in Songname TheRoop he's not executing the Labeling right.
    He's then saying in the Command line Setuservar "NameSong" Thru "eRoop"
    So it looks like if he is seeing the T as a True shortcut in my Variable.

    Is it possible to disable this or is it a bug at the moment?
    Thanks!

    B.t.w. When im saying as Songname @TheRoop instead of TheRoop it's working fine, this because he's not starting with the T.

    I wanna make a small lua script for a Selected Executor.
    Label selected executor for example. Is it possible to make a Lua that makes a Variable of the selected Executor ?

    Hi All,

    Since i've been updated to the new software version 1.8.1.0 i have some jitters on my Dimmer channel when outputting sACN or Artnet.
    Attached a picture so you can see what the problem is. Also attached a Showfile so that you can check what is the problem.
    When you take fixture 101 and move the dimmer channel you can see in the artnet / sacn monitor that channel 25 is jittering.
    He jitters between the program value and the value that he needs to output for a sequence for example.
    When i say On Dimmer and move my dimmer value's, then everything is working fine and not jittering.
    When saying On and than take al the 3 dimmer parameters that i have and the moving the dimmer channel only he is jittering again.
    Already tried to move the Intensity's that i have ( parameter 2 and 3 ) to another Feature group but then still its not working, so the problem looks like a bug in my eyes ?
    When downgrading back 1 version i dont have problems at all so it began from the new software version. Mightbe the problem is that i made a custom fixture and most
    of the users use a fixture from the library ?

    Thanks in advance !