Issues calling Subattributes via Commandline

  • Hey there,

    I´m trying to call subattributes like "Gobo1PosRotate" or "Prism1PosRotate" or "Shutter1Strobe" via commands.

    I tried it with the attributename and number. Sometimes the values are send but to a different attribute.

    E.G.: Attribute "Gobo1PosRotate" at 15 restults in Attribute "Gobo1" at 15.

    Othertimes it does nothing at all.

    Depends on the attribute.

    Does anyone has a clue about that issue ?

    Or do I missunderstand something ?

    Cheers Flo

  • So didn't quite work yet. I played with it and it still gets confused. Firstly, if you try to invoke "attribute gobo1posrotate at + 10" it usually produces a non desireable outcome. I figured out that if I did "attribute gobo1pos" twice to get the value into the programmer and then did "attribute gobo1posrotate at +10", it would work. In fact with a fixture that had a g1 and g2, if I brought the value into the programmer first doing "attribute gobo1pos" x2 "attribute gobo1posrotate at + 10" and "attribute gobo1pos" x2 "attribute gobo2posrotate at -10". It would work. But if a fixture had only g2 rotate-able and I tried to run the same commands, it wouldn't work. in fact when I tried only using g2 commands, it still didn't work. So things are still not quite there.

    The ultimate goal here is to have a macro(s) that increase/decrease the speed of the g1/g2/e/e2 rotation wheels.

  • I'm having a similar problem. I'm using the syntax:

    'Attribute "LayerInputFileSelect" At + 1'

    And the result is that the attribute jumps to half its value, then half again each time I run that line. It does not increase by 1.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!