set command activates set commanddelay

  • Hello,

    I am new in this forum, but I`ve been intensively programming on MA2 for years. On the MA3 software I am running into some errors that might be bugs and therefore I want to report them here. Of course, they also might be result of my own ignorance with the MA3 software and in that case I hope that someone can explain me what I did wrong.

    My first issue came up when I wanted to set a command in a cue via the command line. Whenever I use the syntax 'set cue x command "aaa"' the software ( interpretes this as 'set cue x commanddelay "aaa"'. No matter if I give a string or a number. I even tried other syntaxes, but found no way to change the cue command from the command line.Finally I wrote an XML parch function in Lua to change the command, but it would be so nice if it could be done from the command line.

  • The "Property" keyword can generally be left out when the target object is defined, for example "Cue 1", "Group 'Floor Spots'", "Preset 4.1 Thru 10". If the target object is not defined, for example leaving out the Sequence name or number (to act on the selected sequence) or using an open-ended range (Cue Thru), then you have to use the "Property" keyword or else the PropertyName will be interpreted as the ObjectName instead. So yes, it's possible to leave it out, but certainly safer / good practice to use it.

  • That is very usefull information.
    Now that we´re on the subject I have another question that I have solved for years with XML parching, but maybe you know a better way to do it. The command I want to add to the the cue is a lua command that needs the quotes inside. The set command needs the new command line to be in quotes. This leads to a syntax conflict. Is there a way to add a command containing quotes to a cue from te command line?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!