grandMA3 syntax is missing an escape character

BECOME PART OF THE COMMUNITY - Sign up here
  • Missing Escape Character

    [MA3 1.8.1]

    I am trying to use LUA to set a cue command to run LUA code.

    For example, I want the command to be:

    LUA 'Printf("my name")'

    So I run a command:

    Set seq x cue y command="LUA 'Printf("my name")'"

    This does NOT work, since the " character before "my name", is

    regarded as the closing ".

    Is there a way to escape this " character?

    In lua the escape character is \
    But grandMA3 Syntax doesn't respect that.

    So this doesn't work.:

    set seq x cue y command="LUA 'Printf(\"my name\")'"

    When I run it I get a command with the value:

    Lua 'Printf(

    1) Is there a secret escape character?
    2) Is this simply a missing basic feature?

  • Code
    Set Cue 1 Property "Command" "Lua 'Printf([[It]]..string.char(39)..[[s ]]..string.char(34)..[[MAgic]]..string.char(34))' " 

    Really? Pfft... encapsulating all special characters? Say you want to touch a file on the O.S. you'd need to encapsulate a lot and this will be prone to errors very quickly!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!