syntax: at remove attribute "DIM" is possible...what would be syntax if I want to set the individual delay layer of an attribute at remove ?

BECOME PART OF THE COMMUNITY - Sign up here
  • hey folks, i often have to remove individual delay/fade times from many attributes of fixtures in cues and it is very time consuming to do that manually. is there a way to do it via cmd line. so that i can create a macro. thanks in advance!

  • Probably the easy way is to select the attribute you like in the programmer and choose the Fade layer and from the Calculator Specials choose Remove and Store merge that into the cues in question.

  • hoss the problem about that is that you can only choose "link single"/"link feature" for layers, not "link all active"/"link all" like in MA2...so it is very time consuming to do that for every feature manually...

  • Candela not in MA3. that is my biggest problem with MA3. no possibility to assign a filter at preset pools, which filters relative values/individual fade/individual delay...so i always have to remove that manually if i used any or all of it in my sequence and want to store presets. one example:

    my fixtures point at the wall and run a relative P/T circle. so i have 1 preset called wall which contains absolute values and one preset circle which contains relative values. i save that as cue 1. now i move my fixtures and make them point at the floor while continuing executing the circle. so i change my absolute TILT value, so that the fixture point towards the floor and i save a preset into my position pool. what i get is a combined preset containing absolute and relative values. but i just want to have absolute values in my floor preset. so i created a macro which assigns a remove value to my PAN/TILT preset and then i manually update the preset to get rid off the relative values...here is a screenshot of my macro. and the same problem comes with individual times...

  • hoss the problem about that is that you can only choose "link single"/"link feature" for layers, not "link all active"/"link all" like in MA2...so it is very time consuming to do that for every feature manually...

    I think I understand.


    Does On Fade with no selection work? Then Store /Remove that?

  • hoss on delay/fade works and you could combine that with the AT filter for specific attributes, but when you store /remove it, the absolute value gets removed as well, thats why you have to give it a remove value and merge that. its the same as effect layers in MA2 have changed. if you just activate your effect layer in MA2 and store /remove it, your value layer gets removed aswell...

  • hoss the MA3 software ultimately needs the possibility to filter relative/absolute/time layers. if i remember correctly, there once was a button without function where you could choose between relative/absolute layers in an early software version...i don't understand why they have not implemented such an essential function yet...same for times...but hey, what is the "value" toggle button in the AT filter window good for?

  • hoss but when you store /remove it, the absolute value gets removed as well,

    Right you are. That seems badly bugged. If all that is in the programmer is the fade time I would not have expected it to also clear values that did not have a background color.


    I've seen something similar where it looks like i.fade times get knocked into presets in the programmer when in fact they aren't. when you store you get when you expect but in the programmer it looks wrong.

  • my fixtures point at the wall and run a relative P/T circle. so i have 1 preset called wall which contains absolute values and one preset circle which contains relative values. i save that as cue 1. now i move my fixtures and make them point at the floor while continuing executing the circle. so i change my absolute TILT value, so that the fixture point towards the floor and i save a preset into my position pool. what i get is a combined preset containing absolute and relative values. but i just want to have absolute values in my floor preset. so i created a macro which assigns a remove value to my PAN/TILT preset and then i manually update the preset to get rid off the relative values.

    I am only able to reproduce this workflow issue in v1.6 and earlier, which did activate all layers with content, when a layer was edited

    To my experience, v1.7 does only activate edited layers, and the likeliness of storing unwanted layers is greatly reduced.


    ---------

    that is why something like at remove featuregroup(encoderpage) 2 thru 8 but for the delay/fade layers would come handy...

    try

    Fade Remove

    for all attributes of current selection

    Fade Remove Attribute "Dimmer"

    for specific attribute

    Fade Remove FeatureGroup 2

    for specific featuregroup


    this syntax does not support multiple targets via thru + or wildcard:

    Fade Remove FeatureGroup 2 Thru 8


    if you want to remove special attribute combinations use filters and a macro e.g.


    Filter "AllButDimmer"

    Fade Remove

    Delay Remove

    Filter 1


  • Ahh yes, this is me mis-remembering, how Store /Remove worked.

  • Andreas thank u, i'll try that tomorrow at work! and I am on the newest software version and i when i have a relative circle running, and i modify the absolute layer on tilt, it always activates the relative layer aswell(while being in the cue where the relative circle is running) :(

  • Andreas thank u, i'll try that tomorrow at work! and I am on the newest software version and i when i have a relative circle running, and i modify the absolute layer on tilt, it always activates the relative layer aswell(while being in the cue where the relative circle is running) :(

    Okay thats bit weird because thats not happening to me. I can have a circle running in a cue and then take those fixtures and give them new pan tilt values and store a new preset without relative values.

  • Andreas i have tried your syntax it works fine, thank u for that! the only thing which doesn't work seems to be:

    remove delay attribute "Tilt" for example. it always puts the "remove" value in all attributes somehow...