MA3 OnPC Crashing On Start

  • Hi All,

    I have an issue where crashes upon start. It doesn't open any window, but imdeatelly brings up the crash box, saying MA has crashes, would you like to restart. The terminal app shows the below:

    SetSockOption:Invalid argument
    Failed to set option SO_LINGER on socket Noname (22)
    TerminalApplication has created components
    TerminalApplication is starting components
    TerminalApplication has started components
    Could not open optional file /Users/stjohnscontrol/MALightingTechnology/gma3_1.7.2/terminalapp/config/Console.dat for reading
    Terminal started. type 'exit' to quit
    Unconnected>IP addresses from different interfaces are using the same network! ( vs
    IP addresses from different interfaces are using the same network! ( vs

    The console app shows me:

    UNIX error exception: 17
    flock failed to lock maps file: errno = 35

    Any Ideas of how to sort this or what to look into? - I've deleted and tried to reinstall. Currently I'm using 1.6.7 so its not massively urgent however I would like to get this sorted if possible.

  • Do you have multiple network interfaces sharing the same ip range?

    I Did, however I have just removed them to see if that was causing the issue. With these disconnected / turned off, the app still crashes. GrandMA3 1.6.7 booted fine with multiple network adapters on the same IP range.

  • What happens if you do a clean start?

    Hold down Option then open the Hopefully, you will be asked to continue with a clean start choice.

    Does it still crash then?



    This could be nothing, it could be that the files does not exist or that it's not readable by the current user (which would be weird since it's presumably your user).

    If a clean start does not work you could backup and delete (move) the /Users/stjohnscontrol/MALightingTechnology folder from the terminal.

    mv ~/MALightingTechnology ~/MALightingTechnology.backup

    Then try reinstalling.

  • Hi All,

    Sorry for the delay. The OnPC rig with the issue is only available for me to use in the afternoon.

    Unfortunately launching the app in clean start still crashes on start. Even moving the folder to backup and reinstalling has the same error.

    This is the latest error I have when looking at console:

  • Ahh Mac Entritements.

    Not sure this will fix the issue but try Making sure System Events and Terminal are both Enabled in System Preferences -> Security & Privacy -> Privacy -> Automation.

    I don't recall but you may need to restart or re-login in order for these changes to take place, I don't know for sure.

    Also if you check the items on the left to make sure anywhere else that the is listed is checked where it makes sense (like Files and Folders, Microphone, etc...)

    Else you probably need to contact MA or a local distributor.

  • Unfortunately that didn't work either.

    Weirdly I only have under automation and not

    I'll contact my local MA distributor and see what they suggest.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!