Dot2 to ArtNetToDMX (win11 loopback bug?)

  • Hi All!

    For quite a time I managed successfully to use Enttect DMXUSP pro together with Dot2OnPC (v15 and later v19) bound together with ArtNetToDMX software (from Freestyler).

    However, 'suddenly' It stopped working. I don't get errors - I don't see any data being received by ArtNetToDMX software. The little blue 'lights' in front of "Art-Net Detected" etc do not flash anymore.

    I've but 'suddenly' between quotations because this pc has been updated from windows 10 to windows 11. Because of Corona I haven't touched Dot2 in a while. I could vaguely remember problems that started after I got in ArtNetToDMX software an error ('Error Binding'). I did not look into the issue until now. I can not tell this was before or after the windows 11 update... Could this be it? Windows is famous for great backwards compatibility. Or do I have to wipe my PC and reinstall win10? :')

    My setup:

    - I followed this video exactly.

    - So created a loopback adapter, used as IPv4 address 2-100-100-1, use 'ethernet2' in dot 2, started a new network session, turn ArtNet on in dot2.

    - For settings of Network adapter, ArtNetToDMX software and Dot2 see attachment.

    What I did to fix things:

    - Followed the youtube video again

    - Reinstalled all the software.

    - First started ArtNetToDMX software then Dot2, and another way around.

    - Turned off Wifi

    - Tried different IP addresses (Dot2 wont recognize my node)

    - Googled ;)

    > I couldn't figure out whether the data is not sent out by Dot2 or not received properly by ArtNetToDMX software.

    Do you use the same setup? What are your settings? Did you update to windows 11?

  • Qwerty

    Changed the title of the thread from “Dot2 to ArtNetToDMX” to “Dot2 to ArtNetToDMX (win11?)”.
  • Hi All,

    I tried to listen for Artnet data through different programmes.



    Both I've configurated to listen to the right IP address (as described above) through the Microsoft KM-TEST loopback adapter.

    Both can not capture ArtNet data that is sent out by Dot2.

    So that would tell me eighter the problem is Dot2 sending it to the loopback adapter, or the loopback adapter to the ArtNetToDmx software.

    I don't think the problem is with the end software not capturing it right.

    Dot2 > Ethernet2/Loopback adapter > ArtNetToDmx

    What would you think the problem might be?

  • Hi. I don't have W11 so probably won't help much, but in W10 I had such a problem that if I wanted to have Art-Net over ethernet, I had to turn KMtest off. Try to leave only one connection enabled. Maybe something will help, but I have no way to check ..

  • Qwerty

    Changed the title of the thread from “Dot2 to ArtNetToDMX (win11?)” to “Dot2 to ArtNetToDMX (win11 loopback bug?)”.
  • Yea. Disable it. Try what Krzysztof says.

    If I was using ethernet, I turned off KM test.

    Rather, I used QLC + for testing.

    External Content
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Edited once, last by nasula ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!