Sequence pause when updating linked preset

  • Hi all,


    On MA2 I created a lot of sequences having presets linked, which were updated during show using macro's.


    When doing the same on MA3, the running sequence pauses at the point when I update a linked preset.

    This is both when the preset is recorded in a cue, or when the preset is linked as a recipe.

    The sequence runs again when I turn it off and on (toggle), or when selecting the preset and hit the Go+ hardbutton.


    Is this a known behaviour?

  • On gma2 an Update would knock the updated values out of the programmer. this is currently not the case on gma3.

    Please try in your macros if including a ClearAll, or a knockout of the adjusted values (Off ...), would give you a behavior more similar to gma2

  • Hello,

    my macros for this looks like

    - Blind

    - Group 1 thru 4

    - At Preset 4.1

    - Store Preset 21.3 (in my case i have an 21.3 preset "use executer all"

    - ClearAll

    - Blind


    I have the same problem. If there is an Seq with 3 cues (like All 1, All 2, All 3) and i update the all preset, the cuelist will stop and i have to restart it for the new values. So a realtime update like MA2 is at the moment not possible. I hope that will be fixed.

  • indeed, I experience the same situation, as described above


    also.. I did this in blindedit on MA2, to avoid my programmer to be cleared (when something is in it) when pressing a macro which updates my general preset like described above. Will this blindedit function be available again in ma3 ?

  • did you explore the recipe concept of gma3 yet ?


    Recipe Presets - grandMA3 User Manual - Help pages of MA Lighting International GmbH

    Cue Recipes - grandMA3 User Manual - Help pages of MA Lighting International GmbH


    This can in many scenarios replace the gma2 typical macros of "Blind on -dosomething - store /m Blind off"


    e.g. instead of

    you could create recipelines inside your preset (or directly in the cue) and then merely Assign directly in your macro what you want as content, without even involving the programmer. e.g.


    Assign Group 1 Thru 4 At Preset 21.3.1 Thru 4

    Assign Preset 4.1 At  Preset 21.3.1 Thru 4

  • Hey,

    it all works well so far. But if i use presets from the "Beam" pool, the onPC crashes. Is this a known problem? Other preset pools work, but all from the "Beam" pool crashes (like Iris, Strobe, Frost).