Universal color phaser issue

  • Hello forum,


    Is someone able to explain why there is a color difference when running a color phaser but with a different group?


    The universal color phaser:

    Code
    Step 1; Integrate Preset 4."Red"
    Step 2; Integrate Preset 4."Transparent (Release)"


    Select group 1, select phaser:


    Select group 2, select phaser:


    Same phaser preset but now step 2 has a reference to the phaser itself?

    This not only looks strange, it also adds a blue color to step 1? How is this possible when only a red preset color is used?


    This is the phaser in edit mode:


    The phaser is created with group 1 "COB Mini" where the phaser works as expected, but as it is an universal phaser I would expect it to work for other groups the same aswell.

    When I recreate the phaser with group 2 selected the phaser does work as expected. (It has exactly the same steps integrated)

    But I'm trying to create a 2Step Color FX so the group can dynamiclly change while reference to phaser stays the same.


    So this phaser works, it has the exact same steps integrated only difference is that it is created with group 2 selected.

  • The color-engine takes universal RGB into the colorspace to transform the actual color to the required emitter-values of each of your e.g. R-G-B-W or R-G-B-UV fixturetypes.

    Release-values are not considered in this colorspace transformation process.


    To use the concept of a Transparent Preset, you have to create it with global data, so that it includes Release-values not only for RGB but also for all other emitters like e.g. UV and White as in your scenario.