• Hello everyone!
    So I'm trying to make this work, but I can't figure it out. My goal is to control the console with Qlab via MSC for a show.
    My console and my mac are on the same network ( cables+switch). My console is setup to recieve MSC via ethernet on port 6004. Now on my mac, in the "midi network setup" I'm asked to give three reference about the console: The name, host and port. I've written dot2 for the name ( although I guess it can be whatever I want) and 6004 for the port. But I can't figure out what the host is. I tried to write dot2, it doesn't work.Can anyone help?

    Edited 2 times, last by Yaneck (August 29, 2016 at 3:17 PM).

  • Hello!
    I have to be a little more precise. The problem is coming either from the console or from my mac (not Qlab) (although i know it's me and not the hardwares/software that are doing errors). They are not communicating with each other. To create a Midi network on mac, you have to use "Audio MIDI setup" and go in the networking options.

    here's what it looks like:
    [Blocked Image:]

    To connect my mac to the console I need to tell it what/where/who (I guess) the console is. So I add an entry in the Directory and here is what is asked:
    [Blocked Image:]

    So in the name I wrote dot2, in the host I wrote dot2, and in the port I wrote 6004. Here's the error message I get:
    [Blocked Image:]

    So there i am lost. What would be the host name?

    Thanks for your precious help!

    Edited once, last by Yaneck (August 30, 2016 at 9:15 AM).

  • Hey Yaneck,

    thanks for the details. To be honest we had no compareable support case until now. So for us this is also a little bit tricky! ;)

    But we think it should be enough to type in the IPv4 of the console as the host name. This IP can be found in the setup, by pushing the small "i" in the top right corner. See screenshot!

    Please let us know, if this has solved the issue!


  • Thanks for your help. That kind of sorted it in a way.
    The Midi network has been created, the dot2 is recognized(we can see it under the tab "participants"). So when I click connect, I guess the midi network setup is pinging the dot2. Thing is, after some time (20-30sec) the dot2 doesn't seem to respond to that pinging. I've double checked the addresses and the firewall, everything seems to be fine. Any ideas? Is there a firewall on the dot2 that would block an unknown incoming signal?

    [Blocked Image:]

    Again, thanks for your support!

  • Please give us some time to investigate this. The dot2 has no firewall which can block the incoming signal!
    Do I understand you correctly that the MIDI Network Setup is a part of OSX and not part of Qlab?

    @loeffelandi I didn't get what you want to tell us. For sure we appreciate your help! But please provide in detail what you want to tell us and write clear sentences!! Thanks!


  • Of course, take the time you need, I'm in no hurry and just trying different setups to enhance the workflow in my theatre.

    Yes you understood correctly, Midi network setup is part of OSX and not Qlab. In Qlab you can just specify in which network you want the midi information to go.

    Thanks for your help I realy appreciate it!

    EDIT: A small update, I just tried to add the Mac into the network to see if adding it into the network would turn it into some sort of recipient for a pinging answer coming back from the dot2. It didn't change anything.

    Edited once, last by Yaneck (August 30, 2016 at 1:40 PM).

  • So I tried out different stuff. And I fell on something that looks like a bug? I am not sure if it is the normal behavior.
    So as I said in this thread, the console doesn't seem to respond or even recieve MSC command over ethernet (although I guess this is more some kind of network issue). So if I deactivate the MSC in and activate the MSC out over ethernet and look on the Midi console, everything seems to be normal (aka each time I press go+ a go message is sent via midi.). Now if I activate both MSC in and out over ethernet it seems that the console sends information to itself and enters a loop of go command. Although it might just be me doing something wrong. Here it is in video:!Amx56CZNlTFgi_lk0BQ2ZeGClzmfPg
    So I wondered if maybe we could tell the dot2 from which IP address it is coming it would make the communication easier? Or maybe if we could assign ourselves the IP address of the console to try it out in different network configuration

  • I am not familiar with neither OSX or QLAB, but I am quite sure that Apple's inbuilt support for Midi over Ethernet (AppleMIDI / RTP-MIDI) is not compatible with MA Lighting's implementation of transporting MSC-messages via UDP-strings, introduced in grandMA series1 and predating RTP-MIDI by several years.

    to my understanding (atleast for gma1/2 - I would expect the same applies to dot2)
    first 4 bytes: null terminated string "GMA"
    next 4 bytes: null terminated string "MSC"
    next 4 bytes: total packet length (12 + n)
    next n bytes: the actual MSC string

  • Hi everybdoy,

    it is pretty much as @Andreas said. The implementation of MSC in dot2 (grandMA1 and grandMA2) is based on MIDI 1.0 standard. Apple uses his own standard for the MIDI Network Configuration. This standard is called AppleMIDI or RTP-MIDI. Both implementations are not compatible! :(

    QLab uses the Apple MIDI configuration to send MSC-Commands into the network. To identify all the RTP-MIDI devices in the network Apples Bonjour service is used. Apple Bonjour is a proprietary protocol which is not open for public use.
    If you want to use RTÜ-MIDI-devices which doesn't understand Bonjour, you can assign them by Hostname and Port. As dot2 and grandMA2 can't talk RTP-MIDI, they will not answer and this causes the error „dot2:6004 couldn’t be located. …“.

    @Yaneck: What you could do is that you use a USB/MIDI interface for your Mac. There are several devices on the market. Maybe you contact the QLab support and ask if they recommend a special interface. In QLab you should be able to assign this interface and use it to receive and send MSC. We use a M-Audio Midisport USB/MIDI - Interface for tests here in the office.

    Now if I activate both MSC in and out over ethernet it seems that the console sends information to itself and enters a loop of go command.

    -> this is a normal behavior and not a bug. You've created a command feedback...


  • Thanks for your nice and complete answer!
    Yeah I already use and audio interface for midi. The idea was to travel longer distances with the ethernet cable. But i get it. It's once again Apple's monopolitic commercial ways that screw's it up. Too bad.

    Thanks a lot! appreciated

  • I worked out a way around this by using an arduino to translate the incoming RTP-MIDI packets to MA compatible packets over ethernet. You just plug the arduino into the same network switch as the MA and Apple computer. I have it working on MA2 so I assume it would work with dot2 as well.

    Shoot me a message if you want the code.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!