viz-key with USB Hub

  • Has anyone found success running viz-key through a USB-C hub?

    No problems when connected direct to my mac but finding my results very mixed when using a hub and ports are scarce on the old Macbooks so keen if anyone has found success.

  • Hi Clintos,

    I've tried to connect it with an Satechi USB-C Hub and it's also not working. In the specification of the Hub

    I could see the USB-C port has only a charge function.

    Maybe you can check it with yours.

  • May need a powered hub to supply the Viz-key. as most direct from USB power would be more for Mice and keyboards over outboard gear.
    Not a Mac guy so can't recommend any models for you or even if on the right track. Just going from other touch screen and sound card issues I run into in the past.

  • humm will be worth following to see how it turns out then.
    Guessing may be worth sending a request to your distributor or MA themselves and see how they respond.
    Could be a usb chipset issue or some silly reason the data doesn't like hubs. (my guess security issue thing knowing MA)
    It's nice to have to Viz Key option. but still think it was a greedy and wrong way to deal with the pre viz control.

  • Yes MA are aware of the issue and looking into it.

    Just seeing if anyone else had come across this to aid in gathering as much info as possible.

    I like the Viz Key option, its a token cost compared to the cost of viz software and I find the 512 parameters included SUPER helpful.

  • If by Blue and Black you mean USB port colors.

    Blue is USB 3.0 which is the fastest of the three. Black is USB 2.0 and If I recall correctly White is USB 1.0 The slowest of the three.
    Some devices can be picky as to which they are connected to.

    In general they all can downgrade so plugging a usb 1.0 stick or device into a usb 3.0 port will still work but going the other way may not always work. A usb stick may work but a usb capture card may not. Being a USB 3.0 stick or card into a usb 2.0 port.

    In odd cases you may have a device that is usb chipset specific but I only encountered this once out of all the hardware I ever used.
    As for hubs as the origin of this question was. it generally is either a chipset or power to hub issue in the end.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!