• Dear sirs and madams,

    am I correct in assuming that the desk doesn't run metatables in LUA? i saw that version 5.3 of LUA is implemented, so that should already contain them.

    this piece of code actually works in online lua editors, but not on the desk, and i can't seem to figure out why. i get an error in line 8, attempt to call a table value (global metatable). i changed the Printf into print for the online version, no other changes were made.

    thanks everybody and probably Andreas :)

  • your code works for me and prints 20 in the system monitor, - as long as I add the missing closing tag of the function definition ( " end " )

    make sure that you haven't destroyed the function setmetatable in another plugin or earlier in your code by redefining it via bad code e.g.


    setmetatable = {o,}

    instead of


  • thank you for your super fast response Andreas,

    since it worked with you I restarted the software with clean start, and now it works for me too. Could it be that the link to the lua filename was not good? if i restarted normal software but didn't do the clean start, the problem stays there.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!