MA3 Software update

  • Any one can send exact file for MA3 Software latest updated version-

    I downloaded Latest version from the MA website and try to install as per the instruction given, but not able to update.

    Earlier i updated 1.0 Version, but latest version not able to done.

  • Hello Selvam,

    Can you describe where exactly the update process is failing?

    To download v1.1.3.2, visit the website here.

    Click on Software + Release Notes followed by choosing the download file for your system.

    For MA Hardware, click on grandMA3 Software

    For Windows 10, click on grandMA3 onPC Software for Windows.

    For macoS, click on grandMA3 onPC Software for macOS.



  • Hi Luke,

    It shows that booting file is missing.

    I tried downloaded with different USB Pen drives with different Laptops.

    There are zip files which i had downloaded.

    what are the zip files have to do the unzip or do you want me to unzip all the files.

    Can you send me some image of the file.

    If possible can you please send me the exact files with all the extract has done and mail it me.

    My mail ID -

    Thank You.

  • I had the same Problem on my GrandMA3-light console.

    I tried it with 5 different USB Flash drives and unzipped it with different Zip Programms.

    It doesnt work.

    At least i tried it with an MA-Lighting USB flashdrive and unzipped the files with the Windows Explorer and not with

    a ZIP Programm.

    Then it worked.

  • I Finally updated.

    Once we unzip the files and copy to the USB Pen drive, then there will be a main folder named GrandMA3 Stick..

    We have to cut the " EFI & ma " folders from the main Folder ( Grand MA3 Stick ) and paste the folders directly to the pen drive without any folder or sub folder and delete the Main folder named GrandMA3 Stick.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!