• Hi!

    Considering midi is not implemented... I decided to work thru OSC, but without succes.

    I'm sure about my network settings but a little bit less in OSC grandma3 setting.

    Does OSC is implemented on soft 3 and if yes, what are the setting to trig a simple defgo...?

    All the best!


  • Hi Vesuv, and thanks about your answer!

    Can you please tell me more about configuration?

    For OSC, what need to be fill? Prefix? Page? Fader? Encoder? Key?

    Do you have a scheme for midi 5pin connector if I want to build my own cable?

    Many thanks!

  • OSC configuration is somewhat simple. I haven't played a lot with it but I have been able to make it send and receive without much issue.

    Prefix an optional path prefix for the OSC command. by default the console will send the OSC command to the path of the attached sequence, internally in the console that is where # is the sequence number that the is controlling the OSC messages. For example if you store sequence 99 to executor 201 and move the fader then the outgoing OSC command will be /,sif<string "FaderMaster"><Int:1><float:Value> Adding a Prefix prepends the path with the prefix string. So a Prefix of Audio/Console/Fader makes the OSC output  /Audio/Console/Fader/,sif<string "FaderMaster"><Int:1><float:Value>

    I'm not sure that the Page, Fader, Knob and Key do, I figured they were some sort of filter or remap but it seems he console always sends out the OSC regardless of what I try in those fields, Again I haven't played with it much. I haven't had any luck with the SendOSC command, not sure if that works yet.

    If you need more information on OSC in general you can find the 1.0 spech here.

    As for Midi connections it's simple you only need the bottom two or three pins connected and it's a 5V 220Ohm low bandwidth connection so you can almost use any type of cable.

  • Hey !

    Thanks a lot to all this tricks !

    I don't found yet how to trig a sequence thru OSC, but it will come . I'm using isadora to send OSC, and it work Isadora to Isadora, but not Isadora to GrandMA3. Probably a setting mess.

    I found how to set Midi, and, here is the trick : Add +1 at the note sended .

    E.G : if the sended note is 33, enter 34 inside "midi index" field.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!