ON/OFF-Verhalten von Executoren

BECOME PART OF THE COMMUNITY - Sign up here
  • Hallo liebes MAdot2-Forum :)


    habe die dot2 schon länger auf dem Schirm, aber jetzt endlich ein Projekt mit genug Vorlauf um alles ausgiebig zu lernen. Daher habe ich mehrere Tagen mit euren super Tutorials fleißig getestet und mir brennen zwei Fragen zum ON/OFF-Verhalten von Executoren unter den Nägeln.


    AUTO-OFF
    Wenn Executor A aktiviert ist und ein Executor B die gleichen Werte aufruft wird A ausgeschaltet. So praktisch dieses Feature auch in vielen Fällen ist - für meinen Anwendungsfall ist das sehr unpraktisch: ich habe einen Executor, der die "Home"-Position meiner Moving-Lights angibt (andere Werte als "Center"), wenn diese nicht explizit angesprochen werden. Wird jetzt im Laufe der Show irgendwo mit einem Executor B diese Default-Position aufgerufen, wird Executor A abgeschaltet und die MLs bekommen mit Deaktivierung des Executor B keine speziellen Positionsdaten mehr und fahren somit doch wieder ins "Center".
    Mir fallen zwar ein paar trickreiche Workarounds ein - aber sind die wirklich nötig? Gibt es soetwas wie eine Always-On-Funktion?



    TIMECODE AKTIVIERT CUE IMMER
    Kann man irgendwie verhindern, dass ein Cue auf einem Executor aktiviert wird, wenn der Timecode einläuft? Den zugehörigen Executor auf OFF/0% stellen hilft leider nicht - es gibt zwar keine Dimmer-Ausgabe, aber Gobos etc werden ja trotzdem angefahren. Die einzige Möglichkeit ist ja den Timecode voll manuell für jeden Song im Menü auf OFF zu stellen. Übersehe ich den zugehörigen CMD oder eine andere Einstellung? Einen Record-Befehl gibt es ja ...
    Anwendungsfall wären hier mehrere Songs, die alle bei Timecode 0:00:00 starten, aber nicht immer alle gleichzeitig aktiviert werden sollen.



    Beste Grüße aus Köln
    ;)

  • Hey @spielberger,


    Mir fallen zwar ein paar trickreiche Workarounds ein - aber sind die wirklich nötig? Gibt es soetwas wie eine Always-On-Funktion?

    Die "Workarounds" sind an dieser Stelle wirklich nötig. Eine Option um Off On Overwritten zu deaktivieren gibt es leider nicht. Allerdings ist das Verhalten vone Executor Fadern anders als das von Executor Buttons. Fader haben die Off On Overwritten Funktion standardmäßig deaktiviert. Somit wäre der einfachste Weg für dich wenn du den "Home" Executor auf einen Executor Fader legst. :)



    TIMECODE AKTIVIERT CUE IMMER

    Auch hier gibt es keine Option zu, allerdings kannst du diese Funktion recht einfach mit Commandline Befehlen selbst "bauen". Ich habe mir einen Executor (Flash) gemacht der über die CMD Spalte ein Kommando abgibt, dass bei allen Executorn, Timecode auf Off schaltet. Somit sind pauschal alle Executor davor geschützt unabsichtlich loszulaufen. Meine Timecode Cuelisten haben dazu alle einen Cue 0.5 in dem, wieder über die CMD Spalte ein Kommando ausgeführt wird, welches dann den Timecode für diesen Executor wieder auf MIDI setzt(SMPTE ginge natürlich auch). Das bedeutet die Timecode Cuelisten laufen nur los, wenn ich aktiv Cue 0.5 ausgeführt habe. Hier die Kommandos:


    Timecode auf Off schalten: Assign Sequence "NAME 1" /Timecode=Off; Assign Sequence "NAME 2" /Timecode=Off; usw.


    Timecode auf MIDI schalten: Assign Sequence "Name 1" /Timecode=Midi


    Ich hoffe damit kommst du weiter!? :)



    Beste Grüße,


    Lars

  • Wow! Das nenne ich Support ;) Die Wege funktionieren sehr gut.


    Wenn von "Sequence" die Rede ist, ist also eine Cueliste mit eindeutigem Namen gemeint? Dem Executor kann ich das ja nicht mit "Assign" zuweisen. Da muss ich auf jeden Fall die Gedanken zusammenhalten und nichts nachträglich umbenennen ^^ aber trotzdem eine gute Option.


    Auch wenn deine Lösung mir sehr weitergeholfen hat, habe ich eine Anmerkung zur "Fader Overwrite"-Thematik: Ich hatte das auch schon vermutet war aber total durcheinander, weil es offenbar nicht funktioniert, wenn man einen Button auf einen Fader verschiebt (mit Copy oder Move). Das "Fader Overwrite" wird erst nach dem Restart der Software aktiv, vorher verhält es sich wie ein Button und deaktiviert sich. Erstellt man direkt einen Fader funktioniert es sofort. Umgekehrt gilt das selbe: verschiebt man einen Fader auf einen Button bleibt das "Fader-Verhalten" aktiv bis die Software neu gestartet wurde.


    Vielen Dank für die schnelle und kompetente Hilfe!
    Beste Grüße!

  • Genau das, was ich gesucht habe! Leider fehlt mir eine Kleinigkeit. Ich bringe nicht fertig, den Timecode einer Cueliste durch einen Cue eines anderen Executors auszuschalten.

    Mein Problem ist nämlich, sollte ich eine Song vorzeitig abbrechen müssen, wird mir der letzte Cue nicht ausgeführt, der den Timecode zurücksetzt.


    Auf einem anderen Button habe ich bereits einen Executor mit Cue erstellt, der mir alle laufenden Executoren ausschaltet (mittels Call Macro 39). Hier würde ich gerne weitere Cues erstellen, die mir die Timecodes der anderen Executoren ausschaltet.


    Ansonsten müsste ich bei so einem Fall live in die Executor-Einstellungen wechseln und ihn manuell ausschalten.


    Gibts hierfür auch nen coolen Befehl, den ich in die CMD-Zelle eingeben kann??


    Gruß aus Bayern,

    Timo.

    Edited once, last by VT-Timo: Hat sich erledigt! Man sollte die Cues zum Ausschalten der Timecodes vor dem Cue setzen, der das Macro 39 aufruft... Sonst schaltet sich der Executor selbst ab, bevor er die Befehle ausführen kann! Wieder was dazugelernt! :D ().

  • Hey @spielberger,


    Die "Workarounds" sind an dieser Stelle wirklich nötig. Eine Option um Off On Overwritten zu deaktivieren gibt es leider nicht. Allerdings ist das Verhalten vone Executor Fadern anders als das von Executor Buttons. Fader haben die Off On Overwritten Funktion standardmäßig deaktiviert. Somit wäre der einfachste Weg für dich wenn du den "Home" Executor auf einen Executor Fader legst. :)


    Ich weiß nicht ob ich die Frage falsch verstanden habe, aber die Funktion "Off on Overwritten" zu deaktivieren gibt es bei der Dot.


    Für mein Verständnis nicht das ich es falsch verstanden habe:


    Position A ist auf exec 106 abgespeichert. Position B ist angewählt- sobald Position B deaktiviert wird (oder andere Positionen & Positionseffekte) soll es zurück auf Position A fahren. - Wenn das so sein sollte, dann hab ich es richtig verstanden. Hier die Lösung:


    Lösung A: Die "Auge" Taste drücken und dann auf den Exec Button drücken, in der Position A abgespeichert ist. Es öffnet sich am rechten Screen die CueList von dem Exec Button. Oben rechts befindet sich dann Ein Schraubschlüssel- diesen antippen. In diesem Menüpunkt kannst du dann den Haken bei " Off on overwritten" entfernen. Problem gelöst. Der Exec bleibt im Hintergrund aktiv.


    Tipp: Soll Position A angefahren werden aus einem Positioneffekt, dann muss Position A auch mit einem "Stomp" abgespeichert sein. Sonst fährt der Circle z.B. den Circle weiter- nur eben halt um Position A!