Smart Show Node won't Connect To MA Dot 2

  • Hi All,

    Have just bought a new ArtNet/sACN(E1.31) node it's a Smart Show NetDMX. This is the link to the exact node

    I was under the impression that this node should work with GrandMA Dot 2 as it's on a PDF I found about how to activate your free universe of DMX output (It states at the bottom a list of suggested nodes and "SmartShow" is on there).
    This PDF can be found here:…HB1dCBkb3QyIC0gMSAzLnBkZg

    I have confirmed the Node is working correctly using "Q Light Controller Plus" to check I have DMX output and sure enough all works fine and DMX data is coming out of the node.

    However, I can't seem to get it to work with GrandMA Dot 2. I am running it using a crossover Ethernet cable running directly into my PC, I have set the IP on the Smart show to and a subnet mask of and I have it in sACN mode (I Have attached a screenshot of the configuration page). I have also set a static IP on my PC as well at and a subnet mask of (I Have also attached a screenshot). I will also attach images of my GrandMA Dot 2 configuration page. I am probably missing something simple but any help would be much appreciated.

    Thanks in advance

  • Hi Jack,

    on the last picture you've uploaded we can see that the onPC is using as sACN adress.
    The node uses With this configuration the devices can't talk to each other.

    Please check, if there are any additional IP adresses assigned to the network adapter (advanced settings).

    Everything else of your configuration should be fine! :)


  • Hi,
    When you say advance settings do you mean in MA Dot2 or on Windows ?? And could you let me know how I can access these settings ??

    I have also tried the SetIP command if that’s what you mean but that just didn’t work when I run the command


  • When you say advance settings do you mean in MA Dot2 or on Windows ?? And could you let me know how I can access these settings ??

    I have also tried the SetIP command if that’s what you mean but that just didn’t work when I run the command

    I meant the advanced settings of the windows network adapter settings. So just press "Advanced..." in the "Internet Protocol Versions 4 (TCP/IPv4) Properties" menu. Maybe there is a second IP adress assigned to that adapter.

    SetIP is a command which only works on consoles...

    This is a mistake on my behalf but even when changing the IP address to I still have no luck ?

    Hmmmm this is strange. Some further ideas:

    - does the node answer to ping requests?
    - firwall settings? Can you deactivate the firewall, if it is active?
    - change the IP config back to DHCP.

    Hopefully this helps!? :)


  • Hi,
    My Firewall was active and I have now disabled this, However sill no luck with connecting my node to Dot 2.
    I tried pinging the node and it came back fine with no packets lost. So the node is working fine

    I also changed it back to DCHP but that didn't help much either

    Any ideas ??


  • Did you try to reboot your computer after you've disabled the firewall? We had cases in the past where the changes only became active after a complete reboot of the pc...

    To be honest I don't have any further ideas...what about contacting our distributor Ambersphere. Chrissy has written this document and recommended the node. Maybe she know a little tick to get it working!?


  • Crossover ethernet cable are not required (anymore). if you have a 1gb network adapter.
    The adapter can handle direct links himself.

    Crossover cables are from the past ;)

    I have tried it both with and without a cross over cable but still no luck. if you have any other ideas would be much appreciated

  • Have you corrected the IP as Lars asked for?

    In that dot2 screen shot you can see 192.168. *0* .2
    Maybe a restart was missing here?

    In the adapter setting you entered 192.168. *1*. 2 - which is correct because the node is also in 192.168.1.x.

    there is no switch evolved - only that cable from adapter to node.

    can you ping the node? can you open the webui?
    the firewall is disabled?
    is it really disabled? because of home, company or public networks.

  • Hey,

    i had the same problem and now - thanks to Bob from Smartshow (NetDMX) - i know the solution.

    You need:
    (1) "QLC+" software (passtrough Artnet signal)
    (2) "Microsoft Loopback Adapter"
    (3) Network with 2.0.0.x

    Loopback: Add a new hardware device - select manually - Network adapters - Microsoft - Microsoft Loopback Adapter
    -> Set IP to e.g.

    Set network output of the Dot2 to your new loopback (, activate ArtNet in Dot2 settings (

    Install QLC+, open it, go to input/output, check "passtrough" (top, middle).
    Select Loopback as input (
    Select your hardware network interface (e.g. as output.
    Doubleclick on the output line and insert the IP Adress of your NetDMX device (e.g.

    Now it should work :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!